As discuss with @Anthony we need naming consistency for (service or id) variable. This will help us and other developers.
we are using right now:
- serviceID in coreapi
- hashOrSid in database
Moreover, we have
Name variable in
api.proto.Service struct - which probably was forgotten but is still displayed in cli.
The idea is to:
- remove Name variable from Service struct
- rename serviceID/hashOrSid to … we have two options:
For example docker is calling this variable
And this is how they display it in the docs:
https://docs.docker.com/engine/api/v1.24/ (search for GET CONTAINER LOGS)
➜ core git:(dev) ✗ docker logs -h Flag shorthand -h has been deprecated, please use --help Usage: docker logs [OPTIONS] CONTAINER
We are already using
➜ core git:(dev) ✗ ./dev-cli service logs -h Show logs of a service Usage: mesg-core service logs [flags] Examples: mesg-core service logs SERVICE
So we should use this in API as well and in the source code.